Wednesday, June 11, 2008

ERROR: Exception from HRESULT: 0x81070201

When using STSDEV to create a custom list as a feature, I had my solution deploying and my feature activating without a problem, but then when I created the list I got the error:

ERROR: Exception from HRESULT: 0x81070201

I looked through the log files and found that the Schema.xml file was not included in my feature manifest as an <ElementFile> element. Once I added this it fixed this error

8 comments:

Anonymous said...

Thanks for this Post! Saved me a lot of time :-)

Regards, Simon

Thiwanka Manamendra said...

Thanks bro. This true. It works.

Anonymous said...

In feature.xml, I have defined ElementManifest Location="ListTemplate\SearchFile.xml" />
ElementManifests


But where do I declare schema.xml in ElementFile in element

Anonymous said...

Thank Man. Your my Hero. I followed your instruction and got what I wanted Thank You once again

Windows Native API Reference said...

The <ElementFile> element is not required when you use a folder that contains the 'schema.xml' file and the folder has the same name as the <ListTemplate> element's name attribute. But that requires a seperate folder for each list template.

Windows Native API Reference said...

The <ElementFile> element is not required when you use a folder that contains the 'schema.xml' file and the folder has the same name as the <ListTemplate> element's name attribute. But that requires a seperate folder for each list template.

WYLIESHADOW said...

quick fix for me too. thx!

Russell said...

Thanks for taking the time to post this.